Skip to main content
RACELOGIC Support Centre

VBOX Manager Compatibility

VBOX Manager is compatible with a range of VBOX products. Different firmware versions are suitable for different products, the table below outlines the compatibility between them.
 

VBOX Unit

FW 2.53 b2976

FW 2.55 b2844

FW 3.0 b2186

FW 3.0 b2291

VBOX III

  • Compatible, no major issues found
  • Displays 'Please Wait' but never connects
  • Displays 'Searching' but never connects
  • Displays 'Searching' but never connects

VB2SX

  • Compatible, no major issues found
  • Compatible, no major issues found
  • Displays 'Searching' but never connects
  • Displays 'Searching' but never connects

VBSS100SL

  • Compatible, no major issues found
  • Compatible, no major issues found
  • Displays 'Searching' but never connects
  • Displays 'Searching' but never connects

VB3i (FW V2.5 and under)

  • Compatible, no major issues found
  • Compatible, no major issues found
  • Displays message advising user to upgrade VB3i FW to latest version
  • Connects and correctly sets basic settings, however shows FW V2.6 features which cannot be selected
  • Connects, however FW 3.0 b2186 should be used for full functionality

VB3i (FW V2.6 and onwards)

  • Connects and correctly sets basic settings, however doesn't support FW V2.6 features
  • Connects and correctly sets basic settings, however doesn't support FW V2.6 features
  • Fully Compatible
  • Connects, however FW 3.0 b2186 should be used for full functionality

VB3iS

  • Connects, however FW 3.0 b2291 must be used for full functionality
  • Connects, however FW 3.0 b2291 must be used for full functionality
  • Connects, however FW 3.0 b2291 must be used for full functionality
  • Fully Compatible
  • Was this article helpful?